Geometry model of a 3-D Clevis
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In this exercise you will create an analytic solid model of a clevis by defining MSC/PATRAN points, curves, surfaces, solids, and
a user define coordinate system. Throughout this exercise you will become more familiar with the use of the MSC/PATRAN select
menu. Shown below is a drawing of the model you will build and suggested steps for its construction.

Suggested Exercise Steps:

1) Create a new database and name it Clevis.db.

2) Create a surface model of the top half of the clevis
as shown in the front view on the right side. Place
the center of the hole at [0,0,0].

3) Create solids that represent the first third of the
solid model’s total width

4) Create the bottom half of your model by mirroring
all of the solids about the y-axis mirror plane
located at y=0.

5) Create the remaining solids that represent the last
two thirds of your model in the width direction
(z—direction).

/4

2 Dia

2 Radius
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F'ih' i—frmup Viewport Viewing Display Preferences Tools Help Utilities

Home Geometry Properties Loads/BCs hMeshing Analysis Results Durability

Iy I i T S ST T P A= i &

_ ] |
o | | | - | | | y Wl w v ] | e Bl —
B || |t [R5 (5% || (BB ||| o] o (12| B2 ] T ]
Defauilts Transforms Viewport Display Orientation Misi, Web | |[Model Tree
j=IF
In order to create a new database e : NerEmodEl ExEierEnca ,
You have to do as follows: Model Preference for:
Template Database Name clevis.db
a. File / New... or on a symbol | CAMSCiPatran_x64120122template.db |
New in  Home/Defaults Change Template ., ] Tolerance
section (%) Based on Model
b. Enter clevis as the File name || 7" erermess- ) Defaul
add CIle OK SetWDrking Directory to Database Location
Look in: | L, clevis _:J L] ﬁ Ed~ :Eznﬁgmte f.ﬂEinTILI-I'H
el Limension.
/ New MOde’ Pre_ference Name - Date modified Ty I 10.0
Me items match your search, ! :
c. Select Structural and Click OK
Anahysis Code:
|MSC.Nastran ¥ |
4| T | r 3 TR
b [fic garme: [evis] = o | Analysis Type:
Files of type: IDatabase Files {*.db} L’ Cancel | Cc
| oK | | Reset
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! File—Group  Viewport  Viewing Di Preferences | Tools Help Hilities

Hy 4 Geometry Properties ._c.. Analysis... is Results Durahbility
| ‘:? ~ | E:l & .: Glnhal.... m (@~ |= | s | T
Select || Selact. || ‘Seiect || Select || Seld i et ||le@ ||l S |
% B - x = Mause.., : Action; =
Paints Curves ||Surfaces|| Solids ||Coordi Ficking... pes| Transf b Object
REDCII'['... Method: WYZ ¥

Point ID List

Geometny... -

Finite Efement...

Refer. Coordinate Frame
Coord 0

|:| Auto Execute

Point Coordinates List
[100]

: Geometry | Geometry Preferences |

Geomeiry Representation
d Exportable to Meutral File

Creating a Surface model of a top half of the clevis. [ import to Parametrized Solid
a. Click on Geometry section
b. Create -> Point -> XYZ or chose the method from the list, (._S)Grl.iquré_r.i:gai:r!.fccaut:fennun
enter thevalue [100] and hit  —Apply- O PATRAN 2 Convention
c. Go to Preferences->Geometry s ropery At
d. Check Exportable to Neutral File and hit Apply [ it From Parent

e. Inorder to create a curve from the created point select
Create->Curve Revolve, in Revolve Parameters insert 180
as the value of Total Angle and 4 as a value in section Curves | [Auto Update Sold teshiLBC

NURBS Accelerator

per Point Geometry Scale Factor
f. Choose Point 1 and hit —Apply- (2037007 (nches) 7 |
Reset

The final effect should looks like on the picture above.

I Apply I I Cancel

|.. B il
ol JLZ]
—

by

_iumber | Delete | Associate | Disassociate
'AI

ometry Actions

. | Geometry |

e

o=l

Action:
Object:
veos

Curve ID List
1

Refer. Coordinate Frame
Coord 0

Axis
Coord 0.2

Revolve Parameters
Total Angle
180

Offset Angle

hig!
Curves per Point

S

[] auto Execute

Point List

| Point 1
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You will now use Curvilinear transformation to create the outer
radius of the lug by radially translating the curves that define a
quarter of the hole.
To accomplish this you will first need to create a cylindrical
coordinate frame located at the center of the hole.
a. Create->Coord->3point chose Cylindrical as a Type of
Coord and hit —Appl
b. Transform->curve->Translate check Curvilinear in Refer.
CF, click on newly created coord - Coord 1 as a referenc
coordinate frame and Uncheck Auto Execute.
c. Show labels by pressing |Ex| in Home/Display section.
d. Insert Curve 1 and Curve Z to the curve list

TI P In order to choose more than one curve HOLD
down L.Shift while selecting curve

! Geo me‘tr}r

b

.ééum&t"r.'_.r .
ethos
Coord 1D List
2
Type: CIM -
Refer. Coordinate Frame
| Coord O
Auto Execute
Crrigin
_[EI ooy
Point on Axis 3
[001]
Point on Plane 1-3
[10 I:I_1

+
=
=
i

Object:
Method:
Curve D List

o

Type of Transformation
(:} Cartesian in Refer. CF

@ Curvilinear in Refer. CF

| Coord 1

Refer. Coordinate Frame

Tranzlation Vector

<1 0 0=

Transiation

Parameters

Repeat Count

[ 1

|:| Delete Original Curves

|:| Auto Execute

Curve List
| Curve-{ 2
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You have now created all the curves that you will need to ety | IG&um_mw |
complete your clevis model. Next, you will create the a Action: 3_;“'””7
necessary surfaces for the model. You will start by creating a Object: et
4x2 (inx  Surface that defines part of the upper half of the ' + || wethod:  [curve
clevis body v bl = || suriace s
a. Create->Surface->XYZ insert value <-4 2 0> to define Surface ID List _ |:| |2

Vector, and [-2 0 0] to define point of origin and hit — [ * ; ey —

App|Y— . . Refer. Coordinate Frame ) g Parameterization Method
The next series of Surfaces will be created using the Curve [ Coord 0 . :
Method: ' -

b. Create->Surface->Cur , uncheck Auto Execute and i\":j;gfﬂmates s

select Curve 1 and Curve 2 in a Starting Curve List _— = || [Omanifoid

section and Curve 5 6 as a Ending and hit —Apply- [ Auto Execute |E| =
Click on B in the Home/Misc. section to display the lines. Origin Coordinates List o =

|200] K]
To create the next surface you will use the Select Menu to help e DA”‘?E‘“"’“‘“ :
you define an existing curve and surface edge as the e I%m s
boundaries of the new surface. Iig o
Eaiug tove Lot
| Curve 56

c. Chose Curve 4 as Starting Curve, click B1 and I.click on
edge 9-10 of a surface 1 and hi —Apply-
d. Chose Curve 3 as Starting Curve, click ™and l.click o
Points 8 and 10 while holding |.shift and hit —Apply-
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You will now use the Surfaces you have just created as patterns to define

solids (3-dimensional entities)
a. Create->Solid- Normal, insert 0.25 as a Thickness, Uncheck Auto

execute
b. Chose all surfaces and click —Apply-

y 8 ([ [
Change the view to Iso 1 in Home/Orientation section Il e || el || % || e ||l |

| Orientation

Action; Create ¥

Object: Solid ™
Method: MNormal
Solid ID List

{1

Thicknezs Input Options
{#) Constant Thickness

{:} “arying Thicknesses

Thicknezs

|25

Solids per Surface
1

|:| Flip Surface Mormal

[ ] Auto Execute

Surface List

| Surface 1:5
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Creating the lower part of the clevis

a. Transform->Solid->Mirror

b. To Defin Mirror Plane Normal click the Coord O
Click on the Frame Direction 2 on the Select Menu to point out the
direction of a vector normal to the minor surface.

d. Uncheck Auto Execute, select all solids Solid 1:5 and press —Apply-

Click Display Line in Home/Misc. section L

| G eumé{r'_.r . .

+ O &8

d

|3 (n|1

Method:

Salid ID List
M

L
-

R i alb b A

Coord 0.2

(o

Define Mirror Plane Normal

Offset Parameters
Offzet

0.0
Reverse Solid
[[] Delete Original Solids

[ ] Auto Execute

Solid List
Solid 1:5

o

i -Apphy- ]

This way of representing indicates the two important things:
which Coard is being used and which axis is under consideration

TIP

/

efine Mirrnrﬂﬁle Mormal
Fﬂrd_l}.z

Page 8 of 26




The remaining solids will be created using the translate method.

o 0 T o

Transform->Solid->Translate
Enter <00 -0.25
Repeat Count: 2
Uncheck Auto Execute, choose Solid 1 and 6 and press —Appl

in a Direction Vector section

Your last construction step is to
translate copies of the solids that
surround the hole to create the final

.G&u metry
Action:
Object: Sold ™
Method:
Solid D List
| 23

Type of Transformation
f_?_:' Cartesian in Refer. CF

() curvilinear in Refer, CF

Refer. Coordinate Frame
Coord 0

Translation Vector
|:| Rewverse Direction

Auto Update Magnitude

Direction Vector

1<00-0.25>

Vector Magnitude
0.25

Translation Parameters

Repeat Count
2

solids. Click in the Translation Vector S — T—
databox and clickon *.  in Select ; . ’
Menu = P
= ___Point 10
d. To define the translation R ‘%Ki\
vector, pick Point 10 then ' \\H\
Point 40 as shown below. Use 4 ;
View Corners from Viewing Z/L._X \
* to zoom in. After selecting the o
points use Fit View from f .:j_::m.%_%_
Viewing to zoom out. , R =
e. Repeat Count: 1 4 i o i
f. Select Solids 2to5and 7 to 10 i 2 Jh : f? ‘
Solid 2:5 7:10 and hit —Appl B R
To disable the grid View and enable Body ;\j T ¢ W
press _ in display
lExisE Y menu
m— =] d
Display

[ ] Delete Griginal Solids

|:| Auto Execute

| Solid List
Solid 16

~Apply-



To save the figure of the geometrical mode
a) File/Images...

b) Source: Current Viewport

c) Choose Increment

d) Click Apply

A white background of all figures is obligatory.
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e Apply a non-uniform mesh seed near a critical location of the model.
o Apply a global mesh to the seeded model.
e Apply material and element properties.

Finite Element Model of a
3-D Clevis and Property
Assignment
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Model Description:

In this exercise you will define a finite element mesh for the Clevis model you developed earlier. You will use mesh seeding to create
a refine mesh with a higher mesh density near the bottom of the hole where you will apply a force load in a future exercis

Suggested Exercise Steps:

1. Database opening / creating a new View
Using an isometric view of your model, zoom in
on the lower half of the clevis hole. Save this view as
a named view. Use the name zoom_in.

2. Create the mesh seeds needed to increase th
density in the area where the distributed load will

be applied.

3. Create a finite element mesh using the elemen
topology and size listed in the diagram on the right

4. Create an Isotropic material, named Steel which uses

Mesh Seed
6 elements per edge

Finite Element Mesh
Global Edge Length =10.5
HEXR elements

Linear Elastic

Constitutive Model. The Steel’s Elastic Modulus and Poisson’s Ratio are

respectively 30E6 and 0.30.

5. Create a 3-D element property named, Solid_Elements_Steel, for the entire

includes the steel material definition
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1. New View a Viewing ] Display Preferences Named View Options I
Transformations,.. Current Viewport
Assuming that you have already opened datalﬁ”e Eif o O Yont
Clevis.db , use the Viewing/ Select Corners = Selact Canter :
option to zoom a model in a specific area. —— SO
. . . Zoom B of Viev b | bottom_view P
a. Go to Viewing/Named View Option i vl | teFautt_view l;i
b. Create anew View, name it zoom_in and hit Angles.., | isometric_view |
: | zide_wview :
-Apply- View FromyTo... ?tDD 2 |Z|-

Scale Fadors..,

Kamed:View Options...

Clipping/Perspective.., b _%Wﬂﬂ-ﬂ "

Arbitrary Clipping...

Select Named View

| botto m_view r.
| default_view :
| izometric_view | =
i side_view |
Etu p_view | g
[ Zoom in i)

TH P To simplify the View you i) e
can always hide or display I ﬁ_’!l@llﬁ’”ﬂ|

lines by pressing—only |, || '“"lin?ﬂﬁél

| Z00m_in

model’s boundaries are

Misc.

shown. L -appy- | [ cancel |
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2. Creating mesh seeds Home Geometry Properties Loads/BCs Meshing

e

| | ._'? |:::' e et
a.  Click on Meshing and as fallows : Create->Mesh seed->0ne Way Bias or just |« ||| = E M

clickon |,/ mY:=ir9 ;u Surface Au;;-lmra = g o 521 3¢
b. Insert 6 as a Number (number of seeds on the curve/edge) a 2 asa L2/L1 | mesh seeds || Mesh Contiol || Meshars | FEM action
which indicates seeds varying size along an edge. Uncheck Auto Execute and Finte Elements |
holding L.Shift choose th 1* pair of edges shown in figure and press —Apply- GAEEET:
Do the same for the 2™ pair of edges but invert the L2/L1 to maintain symmetry of the a | Obiect
seeds, thus Number: 6, L2/L1: 0.5 and choose 2™ pair of edg and press —Apply- Type:

[in select menu ( Display Existing Seeds |

Element Edge Length Data

L1 2

- 1
—

@]
TU E@ In order to select edge click on ||§::|

f

(%) Num Elems and L2/L1
This arrow indicates the

L1 and L2
direction of the edge T
Mumber = L]
L2 = ]
[] Auto Execute
Curve List

| Solid 22.1.4 10.1.4

—.ﬁ v
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3. Creating Mesh |~

| | If project is unreadable i'-:.i.ﬂ:f.tﬂfiﬂm&”tsi
Rz @]

(e | el You have to hide Labels | Action:
Create->Mesh->Solid or simply click on |"§.~HE Iid UE@

a. Iﬂiiﬁl and decrease the size of| 4 Object
b. Change eIerr.ment shape to Hex i nodes by pressing in Home
c. Select all solid parts —— section: Type: Solic
d. Uncheck Automatic calculation and insert Value 0.5
: ] i Output 1D List
and hit —Apply | e 1361
Element | 457

b | Elem shape
wesher

Topology Hexg v
[ IsoMesh Parameters. . |
[ Node Coordinate Frames... |
Solid List

C | || ol 1:22

Giobal Edge Length
d [] sutematic Calculation

Value | 0.5

Prof, Mame Mone -

Prop, Type: = Wik

| Select Existing Prop... |
L Create New Property... I
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Now that you have created your finite element mesh, it is time to determine whether you need to
“equivalence the model”. To do this:

| Finite Elements

a

a. Verify->Element->Bounda

check the Free Edges and hit —Apply-

As you can see Your model consist of a group of solids residing next to each other in three dimensiona
space. Since you do not want your model to be in pieces, you must equivalence your model.
Equivalencing results in all the nodes coexisting in the same location, to be reduced to the node with
the lowest ID number in that locatio

b. Equivalence->All->Tolerance Cube, check the Free Edges and —App/

You now have one contiguous model of finite elements. To check whether this is tru : Repeat the step
described in pointa. (Your model should looks like the one below at blue background)

2chaer
Syt
Display Type

(%) Free Edges
() Free Faces

[ Reszet Graphics ]

Y-

Finite Elements |

i
s

=

LA,
I

Node id Options:
LF{etﬂ.ln lower node id

-3

Collapsed Mode Options:
lAI}ow Tolerance Reduction

3

Nodes to be excluded

Equivalencing Tolerance
0.005

Element Boundary Verify

Display Type
(%) Free Edges () Free Faces
[ overty | [ Reset |
Preview Modes
l Preview J |_ Reset I
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Home Geometry Properties Loads/BCs Meshing Analysis Results Darability

Y === |l @i (=] (=

Isotropic |&| |m| Fluid || Cohesive |i||_||&|| _| | '| |ﬁ!|ﬂ'| [t.'| |."| |U‘,| Solid
Lotropic | |Orthotropic) |Anisotropic| |  Fluid Cohesive Composite 0D Properties . 1D Properties ED.Pr-np_erﬁe! I!pﬂ_ﬁes
4. Create an Isotropic material, named Steel, which Waterials > /L
. . . . Action:
uses a Linear Elastic Constitutive Model. Constitutive Model [ — - - ] ction:
Linear Elastic , object
a. Click on Properties / Isotropic Vit
. . Proj MName Value '
Insert Steel as the name of material and click i
Input Properties Elastic Modulus = | 3066 Exing it &
c. Enter Value 30e6 in Elastic Modulus field and Poiz=on Ratio = (0.3 /
. . , . . ¢
0.3 in Poisson’s Ratio and hit OK T | \
d. Check in Material Status if the steel is in c |
Density =
ACTIVE material zone press —Apply- an - 41
Apply- in Materials window Racem L Stk = |
Structural Damping Coeff = | |
LN Constitutive Model Status ference Temperature = l | L Fitter B |
Active Censtitutive Models:
Linear Elastic L
Material HName
b | steel |
Description
Inactive Constitutive Models: Date: 23-Mar-14 Time:
222504
e d
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5. Create a D element property named, Solid_Elements_Steel, or the entire model Element Properties I

which includes the steel material definitio Action:

a. Properties Create->3D-> Solid insert Solid_Elements_Steel as a Property Set a | Object
Name . Type:  [Soid Y |

b. Input Properties Click on % and choose sooner create Steel and hit OK

c. Click on Select Application Region mark whole solid click Add-> OK and —-App

vy foms] @

Select Existing Material

Material Name | pStesl Mat Prop Name -
iSteel

[Mater. Orientation] [ String ™

[Integration Metwork] [ String. ¥

- l Fitter J*

Elsment Properties | Sel&ctAppIicﬁn P_.eéi_un

Property Set Name

Select: | Entiti - -
| Solid_Elements_Steel

Application Region
Select Members Options:

lH omogeneous 2 ]

s [remwe | standard Formulation > ]
Application Region
Solid 1:22 ' b | Input Properties es ... |
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Loads and Boundary Conditions
on a 3-D Clevis

Objectives: Restrain all 6 degrees of freedom
along these faces.

R/

% Apply constraints to your model.

%+ Createand apply a Pressure [

Suggested Ste . \
1. Create a Pressure case

2. Create a nodal displacement boundary
condition named Clambed
3. Create a Pressure boundary condition

Model Description: Area under pressure

In this exercise you will create a loading condition and a P=6900*(1-x%)
constraint set for the clevis model. The base of the lug will be

clamped. The hole will be under quadratically varying
pressure P =6900 *(1 -x2).
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from the list of Independent Variables!!):

and hit -Apply-

1. Creating a pressure case (ATTENTION: ‘X, below, is NOT TYPED, it is chosen

a. Load/BCs // LBC FIELDS->Create spatial function insert Pressure_field as
name check Scalar and Real and insert 6900*(1-'X**2) as a Scalar Function

b. Element Variable/ Pressure, Enter
Pressure as a name, change target to 3D
and click Input Data.

c. Double click on Pressure_field and ok

d. Select Application Region -> holding
L.Shift select all 8 surfaces than click Add-

osd/Boundary Conditions | Input Data |

Load/BC Sat Scale Factor
|1

Pressure

| Pressure_field

e

o EIEL Al
i N1 SIS N | 1E
Element Varia LBC Fields

> OK and —Apply-

C

8 surfaces

i_l I | |_>_ Current Load Case:
Spatial Fields Defautt... |
Prezsure_field Type: Static
Existing Sets gen
[ Preszure .
[ FEM Dependent Data..._ ] |
N New Set Name
[ Pressure '

Target Element Type: [E

plCaTl

Fields |

Action:
Dbject:

Method:

Existing Figlds

| Pressure_field

Field Name
Pressure_fisld

Field Type

(%) Scalar () Vector

Coordinate System Type
(%) Real ") Parametric

Coordinate System
| Lo 1

Scalar Function
| B900%(1-%*2)

Independent Variables
)
-

l Create Variable ..,

[ poy: ]
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2. Create a Nodal Displacement boundary condition:

a. Load/Boundary Conditions Create-> Displacement
->Nodal set name as Clamped

b. Click on Input data and insert <0,0,0> as a
Translation and <0,0,0> as Rotations and OK

c. Select Application Region-> change the filter to
Surface and Add and select surfaces as shown i
figure, click on Add, OK and then —Apply-

Lead/Boundary Conditions |

Action:

Object;

Type:

Option: Standard ¥

Current Load Case:

Defaul...

Tyrpe: Static

Existing Sets

New Set Mame
| Clamped

[ Input Data...

[___select Appiication Region...

Load/Boundary Condtions | Input Data

1:

Load/BC Set Scale Factor

<

Translations <T1 T2 T3=

Trans Phase <Tp1 Tp2 Tp3=

=

f
=1
=1
= |
W

Rotation Phase <Rp1 Rp2 Rp3=

| 000 >

Rotations <R1 RZ R3>

| (2]

|

FEM Dependent Data...

Analysis Coordinate Frame
Coord 0

o | [ Resst |

[ select Appication Region |

Application Region
Select Geometry Entities
Solid 13212211 21.26.412.4 14|

[ ML_J |_ Remove J

Application Region

Solid 12 11:13:2264 121424
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Display both the displacement
and _force _on__the finite

element model

a) Display/Load/BC/Elem.
Props... and check Show on
FEM only and hit —Apply-

b) After that, in Loads/BCs tab
choose Plot markers as a
Action

c) Highlight Displ_Clamped an
—Appl . If you want to show
on the model also a

highlight  al

Press_Pressure before you

pressure,

hit —Apply-

DisplayiPreferences Taals Help

Entity Colar/Label/Render...
Plot/Erase...

Highlight...

Geometry...

Finite Elements...
Load/BC/Elem. Props...
Mamed Attributes, .
Coordinate Frames..,

Titles...

Show on FEM only
Show LBCIEL Prop. Vectors
Show LBC/EL Prop. Values

I ectors/Fitters. ..

| Label Style. .

Beam Dizplay
[ ] Dizplay Pin DOFs
[ ] Dizplay Spring DOF=

[ Coordinate Frames...

Cancel

Lseety | |

Load/Boundary Conditions

[ ] Wodify Veector Dizplay

Current Load Case:

l Default...

Type: Slatic

Aszigned Load/BC Sets
Press Pressure

Group Filter
() Al Groups

{%) Current Viewport

Select Groups
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To save the figure of the finite element model:
e) File/Images...
f) Source: Current Viewport

g) Choose Increment
h) Click Apply

A white background of all figures is obligatory.
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i File Group Viewport Viewing Display Preferences Tools Help Ut

Haome Geometry Propertias Loads/BCs Meshing Analysis Results Durability

S ETEHE I o
0f
SHll @ | .

| b ‘ 1

5 NP

Madel | Group Deck
Analyze Create || Existing Deck || Optimize | |Toptomize

AR PR

Access Results

Entire | Selected || Analysis | Read | Submit |_’“@‘ |,H||§\ DB | Output2 N::-]\BSIELLN HeA9 | diplot }I@_'Hbl\@,\

Delete

DEn LR

i
LIEY

Ations

fis.db - default_viewport - default_group - £n _An.al:,rsl,.is i Solution Type i E | B
M3C Nastran “
i i Solution T +
Run a linear analysis: it i L
=
1. Click Analysis tab scition Type. a X
H H LINEAR STATIC =
2. Set Analysis/Entire Model/ Full Run @ i
. . {T) NONLINEAR STATIC
3. Click Solution Type
. ) () NORMAL MODES -
4. Check Linear static ) BUCKLING N
5. Click OK {7 COMPLEX EIGENVALUE ;
6. Click —Apply- () FREQUENCY RESPONSE
(::}TRANSIENT RESPOMNSE
D NONLINEAR TRANSIENT
(::} IMPLICIT NONLINEAR
(") DDAM Solution
[ Select ASET/OSET...
\v |_ Solution Parameters...
Solution Seguence: 101
.’E]. ' Processing result load case: SCT:DERALLT ‘A‘
$H Processing resul sub-case: Static Subcase
8 Total execution time inredl seconds: 0.000
+H Total execution time in CPU seconds: 01000 i 18 l [ Cancel El
(56 End: Attach Result File = -M

|| $# Reading madel information from the specified database, C:\MSCiProjects\clevishelevis.db.

Analysis \

LH|

Action: Analyze ¥
Oect  |Entre Model ¥
Method:

=}

ode;  MSCMNastran

Type:  Structural

clevis

Job Name:

clevis

Job Description (TITLE)

MSC.Mastran job created on 24-
War-14 at 20:59:04

SUBTITLE

LaBEL

~Solution Type...
Direct Text Input..,
Select Superelements.,
Subcases...

Subcase Select...

Avaiable Jobs E

Translafion Parameters.

|
(«)]
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i File Group Viewport Viewing Display Preferences Tools Help  Utilities

Home Geometry Propertiss Loads/BCs Meshing Analysis
B ‘ 1 B = 7 L
| x op!
— — - || _‘.l .._ - -
Entire | Selected || Analysis Read | Submit || ’H["L‘ XDB Output2
Model | Group Deck =
Analyze | create || Esisting Deck || Optimize |[Toptomize

Results

Durability

B 18 B 5 . 0

“ &) (I

or ||| | | |
A | M| e ([l imﬁ
MASTERY | 116/119'| d3plot |I| RS | Fgp || g ||| e |[ 5! |
DBALL Cb | o || B | |5
Access Results Delete Actions |

5 — alx|
‘Anarysls |
L
(e
analysis job is completed: = - _m
~ yHDF5 :
C||Ck F Code: HSC.Mastran
. . h 5 Type:  Structural
Click Select Result File
. e [w||| Avaisbie jobs B
andsekctChvm.;ﬁUffy = o=
i
necessary
3. C||Ck _Apply Job Name
Job Description (TITLE)
Bellow there is a fragment of UG Hasiar o rstod on 2
the f06 file which contains of a —
infoutput data. This fragment Laget
illustrates distribution of 2 —
the loads. Highlighted value is a
value of resultant fo  working 3
in Fy direction 0
3
0=
NUM
SUBCASE/ LOAD
DAREA 1D TYPE T T2 T3 R1 R2 R3
1 FX -1.0811068E+M1 -—— - ———- 3_.790687E+00 2_749616E+04
FY -—— 45834 06E+03 -—-- 1.718777E+03 -—— -2.750044E+ 0y
F2Z -—— -—— 8.715680E-05 5.994861E-05 5._229468E-04 -——
MK -—— -—— - 0.80AAA0E+ BA -—— -——
HY -—— -—— ———- ———- 0.000060E+ 0@ -——
M2 -—— -—— - - -—— 0.0000d0E+BA
TOTALS -1.0110088E+01 4.583486E+03 8.7156808E-05 1.718777E+03 3.791210E+00 —4.273438E+00
MSC.HASTRAN JOB CREATED OH 24-HAR-14 AT 2@:59:084 HARCH 24, 2814 MSC.HASTRAN 7/ 6/12  PAGE 63
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Post Processing of Stress Results

Objectives:
+»*» To post-process stress results from MSC/NASTRAN
+» To use MSC/PATRAN to create fill and fringe plots to
determine if the analyzed part will meet a customer
defined criteria or whether the part needs to be

redesigned and re-analyzed

Patran 2012 2 64-Bit 25-Mar-14 01:39:31
Fringe: Default, A1:Static Subcase, Stress Tensor, , von Mises, (NON-LAYERED)

39+003

1.66+00

1.54+00

default_Fringes3 :
Max 2.04+004 @Nd 1246
Min 1.39+008 @Nd 1160

Page 26 of 26



CLEVIS
supplement



Create 6 different plots with results:

1) Vertical translational displacements in Y direction

2) Von Mises stress o

equiv

3) Stress in X direction o, with averaging, continuous o,
4) Stress in X direction o, without averaging, discontinuous ¢
5) Stress in X direction o, with averaging, continuous o, for
the base of the clevis (2 different views)

Set white background:
Cycle Background

Follow the steps (numbers in red frames). = |1

Home Geometry Froperties

R :; el Sy =nn|@!ﬁ'ag|

rms| Viewpor -|_'.:'_'?_F'_'?'.3'_!




PLOT no. 1
Vertical translational

displacements in Y direction

1 | Results -> Create -> Quick Plot

9 | File -> Images... -> Apply

-Resurts |

Ohject: Quick Plot = ™™

[ [

Select Fringe Result

Constraint Forces, Translational [A]
Displacements, Rotational [gh

Displacemerts |

Principal Stress Direction, Intermed Prir
Principal Stress Direction, Intermed F‘rir["]
&l | [

Guantity: Y Component b

Select Deformation Result

Constraint Farces, Ratational
Constraint Farces, Translational
Displacemernts, Ratational

Displacements, Translational

|:| Animate

Apply

Results |

Ohbject: __@uick Plat ™

|

Showy Spectrum
Show Wiewwport Legend

[ Spectrum... ] [ Range...
Style: [Discretessmooth > |

Shading;

oo 1.0
oo

W

Element Shrink Factor

Fringe Edges !|
Dizplay: Free Edges %

Style: ——_
wan [—— 7]

( Title Eclitcrr .

Shiow Title [Lock Title

Show MazMin Label
|:| Showe Fringe Lakel

( Label Style. ..

ZShowy on Deformed

8 Apply ] [ Reset




PLOT no. 2
Von Mises stress o

equiv

Results -> Create -> Quick Plot

File -> Images... -> Apply

-Resurts |

Okject:  |Quick Pit ¥

3 F—T— (2]

Select Fringe Result

Strezz Invariants, Méan Preszure [A]
Stress Invariants, Minor Principal g
Stress Invariants, Von Mises i ]

Stre Ensor

£

Select Deformation Result

Conzstraint Forces, Ratational
Canztraint Faorces, Translational
lacements, Ratational

cements, Translational

|:| Animate

Apply

Results |

Ohject: Quick Plot ¥

L]

5

Shaow Spectrum
Shaw Wieweport Legend

[ Spectrum. .. ] [ Range...

]

Style: [Discretessmoth v |

Shading:

oo 1.0
oo

L

Elemert Shrink Factor

Fringe Edges !

Dizplary: Free Edges ¥

CO —

[ Title Editar...

Shiow Tithe [ Lack Title

Shovw Maxiin Lakel
|:| Show Fringe Lakel

( Label Style...

Showy on Defarmed

8

Apply i [ Feset




PLOT no. 3
Stress in X direction o,
with averaging, continuous o,

1 | Results -> Create -> Fringe

9 | File -> Images... -> Apply

Results |

Action:

= & B

Select Result Cases

Default, &1:Static Sub

[f]__m ] (2]

Select Fringe Result

Strezs Invariants, Mean Pressure [A]
Stress Invariantz, Minor Principal i

Stress Invariantz, Won Mises

Stress Tensor,

£3 — "

| Postion...((MON-LAYERED)) |

Giuantity: [}{ Component - 4

|:| Animate

I Apply I [ Reset ]

-Results |

Action:
Object: -Fringe =

=
=| 5
Show Spectrum
Show Wiswport Legend
[ Spectrum... ] [ Range... ]
Style: [Discretessmacth = |

Shading:

0.0 1.0
oa

w

Element Shrink Factor

Fringe Edoes !
Disglay: Element Edoes =

Style: —
wan  [——3]

[ Title Editor ... ]

Showy Title [ JLock Title

Show Maxiin Label
[]show Fringe Latel

[ Label Style..

Show on Deformed

8 Apply i [ Rezet ]




PLOT no. 4

. . . Resultz -| -Results |
Stress in X direction o, e acton
without averaging, discontinuous o, | Ohject:
1 | Results -> Create -> Fringe = = = &
g = =B = o =
Coordinate Transformation:
8 File -S> Ima es -> A I Select Result Cases E
g eee pp y 2 Default, &1:Stati hoase -MSC MAS
Scale Factor 1.0
Filter *alues:
(3 T— 2] All Entities
Averaging Definition: 6 change to
Select Fringe Result Domain: [m (— None
Stress In'-.-'ar.iants, hean Pressure [ 5 -
Stress Invariantz, Minor Principal i ] ethack [Derwemverage b ]
Stress Invariantz, Won Mises = .
3 Stress Tensar, ' {E] Extrapolation :
W
[<]_ L — _.| [?] [Juse pcL Expression
| Postion...((MON-LAYERED)) | [ e
Quiantity: [}{ Component Y | 4 Save Fringe Plot As:
|:|.ﬂ-.nimate
L apply | | Reset | 7 Laeay | [ Reset |




PLOTS: no. 5 and no. 6

Stress in X direction o,
with averaging, continuous o, for the base
of the clevis (2 different views)

Results -> Create -> Fringe

Results

Action:

Ohiject: Fringe ™

Fezuts

Action:

5

i

L]

R

Target Ertity:

Select Elements 6 ‘

Put cursor in Select Elements
and go to the next slide

Addtl. Dizplay Control:

Free Faces ™

L Apply ] l Reszet

=] b
=\l N 5 U E
Select Result Cases i
< (2]
Select Fringe Result
Strezs Invariants, Mean Pressure A
Stress Invariantz, Minor Principal
Stress Invariarts, Von Mizes
F=AE Z:'v:
| Postion...((MON-LAYERED)) |
Giuantity: I}{ Component - 4

|:| Animate

L Apply i [ Reset ]




g || Mark the desired region

9| Click Apply




10

File -> Images... -> Apply

Loads/BCs Meshing

| B f] | I || e || Bz |
11 k|| e |k
. Crientation -

12 | File -> Images... -> Apply

(i

What is the distribution of
the o, stress at the base of
the clevis along the vertical
direction?

‘n —_—




Check the value of the displacement in the direction Y
of the node located on the lower surface of the hole
at the distance 6 [in]:

Reset Graphics

O & o ML 8- Home




Check the value of the displacement in the direction Y
of the node located on the lower surface of the hole

at the distance 6 [in]: —

: Sumimary
Results -> Create -> Cursor -> Vector Object:

Cursar Mame: default_Cursor [ |

Method: Patran 2011
Analyziz Code: MEC Mastran
[

Load Casze: Default, A1:Static Subcaze |
Select Result Cazes Eﬂ‘tit':.l' [n} W WY 7

Select Maodes

Select Curzor Result

Conztraint Forces, Rotstional ~
Constraint Forces, Translational I
Displacemerts, Ratstional | I

Wirite Report J

Stress Tensdr. ' |
| Report Setup. .. J

Reszet Cancel

Position...((HOM-LAYERED)

Target Entity: thiS WindOW
3 Apply ] I Reset WiII appear 11




1| View Corners

Hame Geometry /&\\

SRR

s |i|@]u :
Mark the desired region

rms| Viewport

| ‘-._\ :}‘;’5_'?*1,:“-\\ _535’ i
S ORG2\
L g \

\
I'\:\E';r .J_ .-.- »
:I: \
&
X
/f/,‘\
é
\“\»_:___—"__“




Select the desired node

13




After selection of the desired node you will see:

Node ID

its 3 components of displacement (XX, YY, ZZ)

Read value of YY

SUmmary

Cursor Mame: default_ Cursor

Patran 2011 (=]
Analysis Code: MSC Nastran .
Load Case: Default, &1; Static Subcase s
Select Modes 1
Ertity ID W Wy zz | 2
l Write Report ]
| Report Setup. . J

Rezet

Cancel

14



BEAM

Compare the obtained results from the FE analysis (value of YY, previous slide) to
the deflection of the simple model of the beam.

The beam is fixed at one end and loaded by the same value of force as for the clevis.

The material properties for clevis and beam are the same.

NN\
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BEAM

1. Calculate the deflection of the beam (fpeqm = )

Data:

[ =-- [in] length

b=-- [in] width

h =-- [in] height

E = .- [psi]

P = .- [Ibf] resultant load in Y direction (read from the file clevis.f06)

2. Calculate the relative error.

3. Draw conclusions.



Report should also contain:

a) Figures:
1) Geometrical model (1 figure)
2) FE model with load and boundary conditions (1 figure)
)

3) 6 pIots with the results:

Vertical translational displacements in Y direction
* Von Mises stress O,
* Stress in X direction o, with averaging, continuous o,
 Stress in X direction o, without averaging, discontinuous o,

* Stress in X direction o, with averaging, continuous o, for the base of the clevis (2 different views)

Total number of figures=1+1+6=8

A white background of all figures is obligatory.
A date on the plots with the results is obligatory.

b) Comparison between the obtained results from the FE analysis (value of YY) and

the deflection of the simple model of the beam

- the value of the displacement in the direction Y of the node located on the lower surface of
the hole at the distance 6 [in]

- formula for the deflection of the beam (fyeqm = )

- data and calculations with proper units

- relative error calculations

c) Conclusions 17




